Era bastante molesto después de hacer un downgrade de Firefox 3 Beta al aun estable Firefox 2 en Ubuntu Hardy, en esta ocasión no voy a criticar a la gente de Ubuntu por haber ideado lanzar el Firefox 3 en fase beta en una release LTS (Long Term Support), porque esto ya es bastante comentado en los foros de Ubuntu y en general en la red.

Uno de los principales problemas, es que al querer instalar el paquete «mplayer-mozilla» con el cual podíamos ver vídeos incrustados en sitios web, era que forzosamente nos pedía instalar el Firefox 3 Beta, frustrante, definitivamente. Trate de todo, desde compilar el paquete manualmente, pero gracias a la gente de Launchpad se libero un bug fix (arreglo para el bug), que se empaqueto y esta disponible mediante los repositorios, aunque tenemos que hacer unos pasos previos. Aquí les dejo la información:

Primero vamos a Sistema > Administración > Origenes del Software donde seleccionaremos en la pestaña de Actualizaciones, la opción «Actualizaciones aun no publicadas» (hardy-proposed) y damos click en cerrar.

Esto nos llevara a un mensaje que nos pide actualizar nuestros repositorios.

Despues de esto, recargara la lista de paquetes disponibles

Una ves que termine, abriremos Synaptic, desde Sistema > Administración > Gestor de Paquetes Synaptic y en el botón de búsqueda, introduciremos «mplayer-mozilla» y lo seleccionaremos para su instalación.

Revisamos lo que se instalara para asegurarnos que no esta pidiendo la instalación de Firefox 3 y damos click en Aplicar.